Frequently Asked Questions (FAQ)

 

How do I check if I have the latest Unity Player installed

Navigate to the Unity Web Player plugin page at: http://unity3d.com/webplayer/

Here you will see listed the current version of your Unity Webplayer that is installed. Please makesure you are using the most up to date version of the plugin to run smoothly.

 

My browser tells me that I do not have the Unity Player installed

If you have installed the Unity Web Player from the  to the Unity Web Player plugin page, and the page still listed that the plugin in not installed. 

Here you will see listed the current version of your Unity Webplayer that is installed. Please makesure you are using the most up to date version of the plugin to run smoothly.

 

Unity Player install failed

Please follow these steps to resolve the issue:

Windows:

  1. Close all web browser windows.
  2. Open Control Panel.
  3. Click on Add or Remove Programs
  4. Right click on Unity Web Player
  5. Click Uninstall.
  6. Reboot your machine.
  7. Download the latest version of the Unity Web Player plugin from: http://unity3d.com/webplayer/
  8. Close all browser windows.
  9. Run the Unity Web Player installer.

MacOS

  1. Log onto MacOS with a user account that has admin privileges.
  2. Close all web browser windows.
  3. Delete the file: /Library/Internet Plug-Ins/Unity Web Player.plugin
  4. Empty the trash.
  5. Reboot and log in with an admin account.
  6. Download a new copy of the latest web player plugin from: http://unity3d.com/webplayer/
  7. Close all browsers.
  8. Run the web player installer.

If this does not resolve the issue, make sure Unity is not installed as a plugin in your web browser, by following the instructions below:

Firefox:

Open the browser and click the Tools button -> Extensions -> Plugins Tab (In the newest Firefox you can choose “Extensions” directly).

If the Unity Web Player is listed, please deactivate it, and repeat the steps provided in the top of this guide.

 

I'm using Chrome and I get a message when I play the game.

We recommend using another browser, such as Firefox, Safari to enjoy playing the CreativeMe Game. If you wish to use Chrome for the game we recommend you follow the steps outlined in the NPAPI message.

 

Sorry, Chrome can't run this app

You are using a version of Chrome that does not currently support the Unity Web Player plugin needed to run this app.
We recommend using another browser, such as Firefox, Safari.
Alternatively, you can enable NPAPI plugins at chrome://flags/#enable-npapi (requires browser relaunch).

If you enabled the NPAPI flag and the plugin still does not work for you, try manual install.

 

I can't play the game on my Android, IOS or Windows phone/tablet. 

The CreativeMe Game requires the use of a desktop/laptop machine running Windows or Mac OS.

Other areas such as the Career interview videos and Minecraft Edu videos are available for mobile and tablet devices.

 

MINIMUM SYSTEM REQUIREMENTS

  1. The following are the minimum specifications for running Creative Me Game:
  2. Processor: Dual Core 2Ghz
  3. Memory: 2GB
  4. Graphic card: 128MB memory, DirectX 9 and pixel shader 2.0 capable
  5. OS: Windows and Mac OS.
  6. Supported browsers: Mozilla Firefox, Safari, Internet Explorer 9+